Important information on the trading software

02/08/2019

Dear clients!

Please be informed that on March 1, 2019, some versions of MetaTrader 4 are no longer supported. These are desktop MetaTrader below build 1118 and Android MetaTrader terminals below build 1104.

This means that these terminals will no longer be connected to the broker’s trading servers.

Please check the version you have installed and update your terminal if necessary.

We also recommend to update your servers to the build 1170 dated December 20, 2018.

This version has most of the errors fixed and higher platform stability.